ArtisBrowser - Web Browser : Error when launch

You cannot post Forum | Search |  Register | Login


Group : Guests
Posts : 3
Joined: 2020-04-06

Posted On: 2020-04-06 at 07:06

Hi, can someone help me. I got Error code: 2
Critical Failure
The browser failed to load a critical component and will now quit to prevent data loss.

What is the cause for this error? Can explain?
I''m using Windows 10 and I download the software from your website. Thank you.


Group : Admin
Posts : 128
Joined: 2016-09-29

Posted On: 2020-05-08 at 18:30

On Windows 10 you may need to disable UAC and use "Run as Administrator" to overcome the limitations imposed on software installations that operate at system level.

In such cases when installing or running, always right-click to select "Run as Administrator".

Anti-virus software can also prevent software from running, and if the application cannot be whitelisted to allow to run, then that anti-virus software can be deemed useless and should be replaced with one that does.


Group : Guests
Posts : 1
Joined: 2020-06-08

Posted On: 2020-06-08 at 07:33

I am getting the same error on a new installation even with these suggestions:
Critical failure. The browser failed to load a critical component and will now quit to prevent data loss.
Error code: 2 (You can copy this message by pressing Control-C combination)

It popped up right after installing ArtisBrowser and pops up every time I try to run the browser. This is on a fresh installation of Windows with the new version of ArtisBrowser. The install goes fine and successfully completes right before the error pops up. The system is Windows 10 Pro 64-bit. It's a Dell desktop. I tried turning off UAC, Windows Firewall, and I disabled my antivirus also. I removed and reinstalled the browser after changing each setting. I run the install as administrator and I tried running the browser as administrator. I also played around with the program compatibility settings, running under Windows 8, Windows 7, and Windows XP SP3 compatibility.

This has me stumped. Nothing gets logged to the Windows application error log when it happens. This is the weird thing. I have another PC with the same Windows version that runs ArtisBrowser with no problem. That PC had older versions of ArtisBrowser previously installed. That is the only difference I can think of other than the trouble PC is a Dell and the PC that works fine with ArtisBrowser is an HP. It runs the newest version without the error.

Both PCs are 64-bit, but the HP has a better CPU with 8 cores. the Dell is dual-core. Both PCs are on a Windows domain with domain administrator logged in. I checked the domain policy that controls the PCs just to make sure there are no app restrictions there.

Thanks for any help.


Group : Admin
Posts : 128
Joined: 2016-09-29

Posted On: 2020-09-04 at 23:58

Brand new install?

Your computer may be missing resources that are provided via Windows updates. For example, this error is typical when running on newly installed Windows without updates.

Please ensure that your computer has the latest Windows updates.